Solution: Linux JDeveloper 11g (R2.3) Embedded Weblogic starts too slow

I had first discovered that for some strange reason,embedded wls runs much slower on linux when compared to windows xp given the exact same hardware.
https://wesfang.wordpress.com/2012/08/20/jdev-10-vs-11g-day-3/

Upon further investigation on google, I found the following blog post:

http://www.itonguard.com/20090313/weblogic-starts-slow/

The author states a common issue with slow starting of wls under linux. The solution is to modify $JAVA_HOME/jre/lib/security/java.security file with the follow line

securerandom.source=file:/dev/./urandom

For my linux setup(ubuntu 12), the JRE that embedded wls uses is under:
/Oracle/Middleware/jdk160_24/jre

Whats strange is the default value is missing “./”
securerandom.source = file:/dev/urandom

Following the blog instructions, replace the value with
securerandom.source=file:/dev/./urandom

Now go back to jdev and run your app, the wls should start much faster!

Advertisements

About wesfang

www.linkedin.com/in/wesfang/ https://twitter.com/wesleyfang
This entry was posted in Uncategorized. Bookmark the permalink.

One Response to Solution: Linux JDeveloper 11g (R2.3) Embedded Weblogic starts too slow

  1. Pingback: JDev 10g vs 11g – Day 3 | wesfang

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s